WordPress插件 - 自动更新插件: Auto-updates

WordPress自动更新需要以下条件

  1. 网站程序及数据库需要及时备份;
  2. 网站不能自动更新,包含程序,插件,主题不能自动更新。

主要解决的问题

  • 提升网站的安全性

具体分析

插件修改代码的很少,更新不会有问题;

主题有可能修改代码,改变功能,这个自己的网站要心里有数,在备份的时候,可以做策略,这样及时回传覆盖更新即可;

程序升级,如果是一直连贯的升级,不会出问题,跨版本升级WordPress做的也不错,几乎也不会出错。

在网站安全性的大前提下,自动更新还是非常有必要的,因为涉及到网站环境及权限的问题,有些WordPress网站无法自动更新。使用插件是很好的解决办法,而且这款插件是WordPress官方开发的,并且会在WordPress 5.5中集成到WordPress程序中。

背景知识

关于WordPress自动更新,WordPress官方从2013年开始讨论,但一直没进展,鉴于WordPress一直有安全性问题,所以自动更新是有必要的,特别是针对插件和程序本身。

一些设想

自动更新插件和针对每个插件,每个主题设置是否需要自动更新。

但没有设置邮件提醒的功能,而且也没有设置备份之前做备份的功能。

当然还可以有日志功能,这样才是一个功能完善的插件。

插件官方地址

插件官方地址

人已赞赏
WordPress插件

WordPress插件 - 经典编辑器:Classic Editor

2020-7-8 14:54:11

WordPress插件

WordPress插件 - 功能插件:Flamingo

2020-7-8 15:09:26

下载说明

  • 1、微码盒所提供的压缩包若无特别说明,解压密码均为weimahe.com
  • 2、下载后文件若为压缩包格式,请安装7Z软件或者其它压缩软件进行解压;
  • 3、文件比较大的时候,建议使用下载工具进行下载,浏览器下载有时候会自动中断,导致下载错误;
  • 4、资源可能会由于内容问题被和谐,导致下载链接不可用,遇到此问题,请到文章页面进行反馈,以便微码盒及时进行更新;
  • 5、其他下载问题请自行搜索教程,这里不一一讲解。

站长声明

本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有;若为付费资源,请在下载后24小时之内自觉删除;若作商业用途,请到原网站购买;由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索